l dont use vb5 only vb4 :)