PDA

View Full Version : 5.x.x vBulletin 5.6.4



puertoblack2003
6th Nov 2020, 20:13
little late uploading been busy lately..as always major props to vbsupport.org

As always help support vbulletin-mods by donating. !!!

vBulletin 5.6.4 Updates and Changes


vBulletin 5.6.4 is now available for download. vBulletin Cloud customers will be updated automatically in the upcoming days.


Front End Changes


Lightbox


The attachment system now uses the Lightbox display for all image content uploaded to the server. If the user has permission to view image thumbnails but not Images, then the lightbox will only show thumbnails. When clicking on the "More Photos" link in a Photo Gallery, the lightbox will be displayed appropriately.


In addition to this, the code for the lightbox has been updated and had several fixes applied. These fixes should allow for more accurate scrolling and the ability to select the last image in the list correctly.


Photos Tab


The Topic display now includes a Photos tab. This tab will open a gallery view of all gallery and photo attachments within the topic and allow users to view them in a paginated format.


Media Albums


Along with the general lightbox updates, Media Albums within the user profile now support proper pagination.


Other Issues



The system correctly inserts the Meta Tag to discover the XML sitemap better if you do not have it added to your custom robots.txt file.
CSS has been added for the proper highlighting of search keywords in search results. You can change the background color used here with the search_result_highlight_color style variable.
The browser should no longer attempt to submit the login form if Javascript is not functioning.
Modules should properly create channel lists within their options again.

PHP Module


The PHP Module is no longer available. Please use a custom API and the Display Template module to replace this functionality. For more information on implementing these changes, see this article:
https://forum.vbulletin.com/node/4445230



Back End / AdminCP Changes


Template Processing



Removed the ability to {vb:raw var.{vb:raw subvar}} from template syntax. The accepted format is {vb:raw var.$subvar}. Any template modifications using the former will need to be updated.
Removed obsolete {vb:link} template directive. The proper directive to use is {vb:url}.

Database Updates



The user.status field is now in the usertextfield table. This change will help prevent rows in the user table exceeding MySQL's allowed row size.

Additional Issues



Updated the processing of custom CDN URLs so that CSS and SVG files work correctly again.


Additional Information


PHP 8


PHP 8 is due to be released in December 2020. At this time, vBulletin 5.6.X is not compatible with this version of PHP. There is ongoing development to ensure that compatibility with PHP 8 will be available before it is released.


Install / Upgrade Instructions



Installation Instructions (https://www.vbulletin.com/forum/node/4391348)
Upgrade Instructions (https://www.vbulletin.com/forum/node/4391346)

File Cleanup


After upgrading your vBulletin system, you should delete any possible obsolete files. You can obtain more information on why this is needed and instructions on how to do this here: topic (https://www.vbulletin.com/forum/node/4391346) in the vBulletin 5 Installs & Upgrades forum.


System Requirements


Minimum System Requirements



PHP Version: 7.2.0
MySQL Version: 5.6.10
MariaDB Version: 10.1.0

Recommended System Requirements



PHP Version: 7.3 or higher
MySQL Version: 8.0 or higher
MariaDB Version: 10.3+

For more information, see vBulletin Connect System Requirements (https://www.vbulletin.com/forum/node/4391344).


Current Version Support Schedule



Active Version - 5.6.3
Security Patch - 5.6.2
Security Patch - 5.6.1
No Patch Release - 5.6.0 and earlier

teet1
21st Feb 2021, 02:48
Hi im trying to install, but its asking for License number and i cant install or upgrade.

puertoblack2003
25th Feb 2021, 02:05
Only registered members can view quoted posts.

it appears it wasn't properly nulled. but surprising no one complained about it. download the file and put it in core/install folder and over write file.

---------- Post Merged at 20:05 ---------- Previous Post was at 19:57 ----------

and make sure t he config.php.bkp in th

Kageknight
3rd Apr 2021, 10:48
Only registered members can view code.

When trying to install, I simply get this right after it tells me to delete the makeconfig.php file. Any thoughts?

CaptainKirk
21st Oct 2021, 21:06
Kageknight, I am going to take a wild guess that you're running PHP 8.0? I am pretty sure vBulletin v5.6.4 is not compatible with PHP 8.0. If you are running PHP 8.0, back your PHP down to 7.4 and see if that takes care of the error. Good luck. :teapot:

asuawebradio
26th Oct 2021, 01:51
How do I download this version?